Possible bug: placing multiple triggers on the same tile

Discuss IB/IBx engine ideas, bugs, etc.
Post Reply
Pongo
Posts: 144
Joined: Fri Jan 22, 2021 8:39 am

Possible bug: placing multiple triggers on the same tile

Post by Pongo »

I'm having difficulty placing two triggers on one tile in v197. I think there might be a bug.

The player will be going in and out of the main castle location a lot, so to keep it fresh I had the idea that the guards on the gate might comment on the player's progress from time to time as you walk past them (as floaty text rather than a convo, so as not to slow things down too much).

So I currently have two triggers placed on the same tile, guards1 and guards2, which activate different floaty text comments. Guards1 works fine - when the players walk past the guards for the first time, they get a bit of banter.

Later, after a quest has been completed, I use gaEngableDisableTriggerEvent to turn off the first bit of floaty text (guards1, events 1 and 2). This also works fine. But then using gaEnableDisableTriggerEvent does not turn on guards2 events 1 and 2.

I've played around with it a bit and I'm fairly sure its not an input error. I tried adding guards2 to a different tile, and then it works fine. The problem is when two triggers are on the same tile. I think this is a bug?

Also, when I select the trigger on the map, if I’m in the “properties” tab then it updates to show the information from either of the selected triggers and I can update it. However, the “TriggerEvents” tab will only show data from guards1 even if I have selected guards2 to work on. TriggerEvents doesn't seem to identify when there are two separate triggers on the same tile.
Post Reply