Size 3 (1x2) enemy bug

Discuss IB/IBx engine ideas, bugs, etc.
Post Reply
Pongo
Posts: 142
Joined: Fri Jan 22, 2021 8:39 am

Size 3 (1x2) enemy bug

Post by Pongo »

Slight bug I think in the size 3 enemies in version 197.

I'm using the pool of radiance ogre. The token is 100x400, with an inactive 100x200 pose and attacking 100x200 pose. The inactive token works well, but when the ogre attacks the token stretches and looks weird. Its just a graphical glitch so no big deal but flagging for a future fix.


ogre1.png
ogre1.png (592.11 KiB) Viewed 1731 times
ogre2.png
ogre2.png (556.33 KiB) Viewed 1731 times
User avatar
Dorateen
Posts: 262
Joined: Thu Jan 16, 2020 3:03 pm

Re: Size 3 (1x2) enemy bug

Post by Dorateen »

Pongo, what I did for large sized creatures is to use 200 x 400 tokens (size 4) even if they were tall, or even wide (100 x 200). Anything bigger than the standard 100 x 100, used size 4 and there was no stretching. I don't know if that would be a good solution for you, but that is how I worked with large creatures.
User avatar
slowdive
Site Admin
Posts: 485
Joined: Wed Jan 15, 2020 4:37 am

Re: Size 3 (1x2) enemy bug

Post by slowdive »

Thanks for the bug report, this looks like an easy fix. I may take a crack at some bug fixes and adding some of the IBbasic features to IB once I have IBbasic up and going in a few weeks. I’ll need to research how to safely make a pull and push on GitHub that doesn’t mess up any of Karl’s work. Maybe I need to make a branch and then he can pull/merge any of my additions?

Side note: IBbasic is only using size 1 and size 4 so I’m doing exactly what Dorateen is doing.
Pongo
Posts: 142
Joined: Fri Jan 22, 2021 8:39 am

Re: Size 3 (1x2) enemy bug

Post by Pongo »

ok - thanks both for the help and replies!
Pongo
Posts: 142
Joined: Fri Jan 22, 2021 8:39 am

Re: Size 3 (1x2) enemy bug

Post by Pongo »

Creature sizes don't seem to be working in v199.

These orcs are 100x200 (for an idle/attack png) - set to size 1 in the editor:
1 tile creatures.png
1 tile creatures.png (485.42 KiB) Viewed 1546 times

These ogres are 100x400 - set to size 3:
1x2.png
1x2.png (609.35 KiB) Viewed 1546 times

And this giant spider is 200x400 - set to size 4:
2x2 creatures.png
2x2 creatures.png (609.83 KiB) Viewed 1546 times


I thought it might be something to do with the changeover from v197, so I've tried removing and replacing some of the creatures but it doesn't fix it. In v197 size 1 creatures worked fine for both idle and attack; size 3 worked for idle but not attack; I hadn't tried size 4.
User avatar
slowdive
Site Admin
Posts: 485
Joined: Wed Jan 15, 2020 4:37 am

Re: Size 3 (1x2) enemy bug

Post by slowdive »

Something weird happened there, I had tested all sizes. I'll have a look and see if there is somewhere else in the code that may not have been changed or if some was undone.

Love the sticky boots blood mage spell ;-)
User avatar
slowdive
Site Admin
Posts: 485
Joined: Wed Jan 15, 2020 4:37 am

Re: Size 3 (1x2) enemy bug

Post by slowdive »

I was able to track this issue down to the use of the "useCombatSmoothMovement" flag set at false. I will need to update the creature draw code for that situation, but I tried a couple of quick changes that didn't work. It will take some work probably due to the complexities of the panning of the combat map system. Stay tuned.
User avatar
slowdive
Site Admin
Posts: 485
Joined: Wed Jan 15, 2020 4:37 am

Re: Size 3 (1x2) enemy bug

Post by slowdive »

Okay, I think I have it fixed now so that those who are not using the smooth combat movement system will now draw creature sizes correctly. I'll post v1.0.202 in a day or two (once I've done some more testing in a few modules).
Pongo
Posts: 142
Joined: Fri Jan 22, 2021 8:39 am

Re: Size 3 (1x2) enemy bug

Post by Pongo »

Good work, thank you!
Post Reply