v203 Bug: Damage adder

Discuss IB/IBx engine ideas, bugs, etc.
Post Reply
Pongo
Posts: 111
Joined: Fri Jan 22, 2021 8:39 am

v203 Bug: Damage adder

Post by Pongo »

I think there's a bug with the damage adder.


I have some ogres with +5 damage:
4ogre.png
4ogre.png (34.2 KiB) Viewed 66 times

However, they don't actually add the damage. They only do 1-6 damage, as below where "dwarf fighter" is hit for just 4 damage:
4dam.png
4dam.png (371.01 KiB) Viewed 66 times

I thought this might be linked to prop size somehow, so I shrunk them to size 1. It didn't help. I've tried deleting and replacing the prop, and that didn't help either. None of the PCs have damage reduction.

What made it a bit confusing is that the damage adder does seem to work sometimes. For example, there are these nasty golems with +7 damage:
golem hit.png
golem hit.png (31.33 KiB) Viewed 66 times

Here, the golem is hitting with its first attack for just 4 damage, but a whopping 14 damage with its second attack:
golem.png
golem.png (217.22 KiB) Viewed 66 times

It looks like the damage adder is being missed out from any creature's first attack but added for second attacks?

EDIT: actually, that 14 damage looks like its a critical hit. I'll check that again.

EDIT 2: ha no, sorry, the critical hit is the one that did 4 HP damage!
User avatar
Dorateen
Posts: 179
Joined: Thu Jan 16, 2020 3:03 pm

Re: v203 Bug: Damage adder

Post by Dorateen »

I think this might predate build 203. A while ago, I noticed the damage adder did not seem to be applied, or that monsters with it wer doing low amounts of damage. I stopped using that property, and just lump it all into the base damage. So an ogre who does 1d6 + 5, I would just make 11. Your golem's base damage looks like 2d8, so the 14 falls within that range, it might not be applying the +7.

Anyway, I agree there is likely some issue with the damage calculations ignoring the damage adder.

Love the screenshots!
Pongo
Posts: 111
Joined: Fri Jan 22, 2021 8:39 am

Re: v203 Bug: Damage adder

Post by Pongo »

Thanks Dorateen!
yes, you're right - the 14 damage was within range (my maths, honestly...!). I just played that encounter out (my LVL1 party didn't last long) and the golem only ever hit within 2d8 for any attack, first or second. Damageadder isn't working in any circumstances, it seems.
User avatar
slowdive
Site Admin
Posts: 372
Joined: Wed Jan 15, 2020 4:37 am

Re: v203 Bug: Damage adder

Post by slowdive »

I'll look into that, but it does seem like it is missing the damage adder.
Post Reply